127.0.0.1 è accessibile lavoro ma localhost non accessibile/ non funziona

Sto usando wamp per alcuni anni e ho aggiornato a windows 8, alcuni mesi prima, la mia wamp di lavoro senza intoppi fino a ieri. Ma ora non si può accedere tramite localhost. ma quando ho trying 127.0.0.1 invece funziona senza problemi. Ho cambiato ::1 localhost per 127.0.0.1 localhost nel file host. quale soluzione proposta per il problema nella maggior parte dei siti web. Ma purtroppo il suo non è un lavoro per me. Quando ho ping localhost mostrando il suo replay ::1: time<1ms. E non C’è nessun software che utilizza la porta 80 ho già controllato. si prega di aiutare a risolvere questo problema.

  • quello che non si vede se si ping localhost?
  • mostrando il suo replay ::1: time<1ms
  • disinstallazione di teamviewer risolto il mio problema
InformationsquelleAutor JOE | 2013-12-03



8 Replies
  1. 1

    Modifica

    %SystemRoot%\system32\drivers\etc\hosts

    e sostituire

    ::1 localhost

    con

    127.0.0.1 localhost

    Salvare e riavviare apache.
    Spero che possa funzionare .

    • Ho già cambiato. Ma ancora non è il suo lavoro
    • potresti postare qui quello che il file hosts contiene
  2. 0

    Aggiungere 127.0.0.1 localhost nel file hosts.

    Se c’è un # (cancelletto), davanti ad esso, rimuoverlo.

    Rimuovere altre istanze di localhost, o mettere un # di fronte a quelli di altre istanze.

    Il file hosts è di solito in c:\windows\system32\drivers\etc\hosts, e quando si tenta di modificare questo file eseguire il blocco note (o qualsiasi altro editor preferito) come AMMINISTRATORE, altrimenti le probabilità sono grandi che le modifiche non saranno salvate.

    Dopo aver fatto tutto questo, nel browser, fare un controllo-f5 (aggiorna senza usare la cache).

    • Ho già cambiato, non il suo lavoro. Ma quando ho ping localhost mostrando il suo ‘replay ::1: time<1ms’
    • quindi avete ancora un altro esempio di localhost nello stesso file.
    • No, c’è solo un esempio.
  3. 0

    Per un problema di DNS:

    ipconfig /flushdns

    ipconfig /registerdns

    o piuttosto di backup il codice e reinstallare il wamp server.

    Molto più veloce soluzione, tuttavia, ricordare che sei wamp impostazioni.

  4. 0

    Dopo aver aggiunto la riga 127.0.0.1 localhost il file hosts, copiare il contenuto del file hosts e incollarlo in un altro file, quindi sostituire il file host con uno nuovo. Questo ha funzionato per me.

    • Grazie per il tuo creando pregiati tempo. Il problema è stato risolto già da quando ho reinstallato windows.
  5. 0

    Risolto il Problema modificando il file /etc/hosts:
    Anche io ho avuto il problema simile(in Grado di eseguire il ping 127.0.0.1, ma il problema, mentre il ping localhost). Ho risolto togliendo
    voci come
    ::1 localhost, ff81::1%lo0 localhost
    con solo 127.0.0.1 localhost….
    Ho rimosso il resto delle voci di localhost. Ho fatto questo per il mio mac.

    Dopo questo processo sono in grado di eseguire il debug l’applicazione java con eclipse.

  6. 0

    È possibile rimuovere il commento (# fila) o aggiungere
    127.0.0.1 localhost
    Negli host (cartella, ecc)

    Aprire questo file con privilegi di admin

  7. 0

    Questo problema si pone anche se hai modificato il tuo vhosts.conf file e aggiunto un host virtuale. Per risolvere commentare ogni riga del virtual host voce, ad es.
    Se l’utilizzo di xampp, modifica la tua voce in vhosts.conf e commento di tutte le linee (aggiungere un # all’inizio di ogni riga)

      ##<VirtualHost *:80>
        ##ServerAdmin [email protected]
        ##DocumentRoot "E:/xampp/htdocs/dummy-host.example.com"
        ##ServerName dummy-host.example.com
        ##ServerAlias www.dummy-host.example.com
        ##ErrorLog "logs/dummy-host.example.com-error.log"
        ##CustomLog "logs/dummy-host.example.com-access.log" common
    ##</VirtualHost> 

    poi commento o aggiungere 127.0.0.1 localhost nel tuo file hosts.

  8. -1

    Mi sono imbattuto nello stesso problema con XAMPP sul mio Mac e (finalmente) capito come risolvere il problema. Qualcosa di simile potrebbe funzionare per voi in Windows:

    Anche se il mio file /etc/hosts sembrava corretto, ho avuto la sensazione che non stava funzionando. (“ping localhost” non ha restituito risultati, ma “ping 127.0.0.1” era funzionante). Così, ho trovato che c’era una copia del file host originale (/etc/hosts~orig) che ho sostituito il mio attuale file hosts con. Che ha fatto il trucco dopo il riavvio di Apache.

    $ sudo mv /etc/hosts /etc/hosts~old
    $ sudo cp /etc/hosts~orig /etc/hosts
    $ ping localhost

Lascia un commento