activity_main.xml: non è Riuscito a trovare lo stile corrispondente all’id 2130771996

Sto Avendo problemi mentre si crea un nuovo progetto in Eclipse Luno.
Dopo l’aggiornamento di Android Eclipse SDK, API 22 poi devo iniziare a ricevere questo problema,
Il Layout non è visualizzato correttamente nel Layout Grafico di activity_main.
Questo è il Link ad Immagine di Come il suo sguardo, Quando ho creato il Nuovo Progetto

per mostrare il layout che ho bisogno di trasferire in API 20 allora funziona.
Gli errori sono solo mostrando nel Log degli errori non nella sezione del Problema.
Questo è il Log di Errore

Qualsiasi Aiuto Per Favore.

P. S. è OK, quando ho selezionare API di Livello 20, quindi il Layout è totalmente bene e normale senza errori.

  • Si prega di inserire le vostre risorse nel post, se possibile, in modo da evitare offsite dependnecies che potrebbe scomparire anche se la tua domanda a vivere.
  • Non ho abbastanza reputazione per aggiungere l’immagine che è il motivo per cui ho usato fuorigioco dipendenze.

 

9 Replies
  1. 40

    Provare a cambiare di versione inferiore, come mostrato nell’immagine qui sotto e dovrebbe funzionare:

    activity_main.xml: non è Riuscito a trovare lo stile corrispondente all'id 2130771996

    • Sì l’ho fatto e Funziona tutto Bene 🙂 Ma che Cosa è la ragione che la sua non mostrando con API 22
    • Questo è possibile poiché alcuni di obsoleto classi potrebbero non essere supportate superiore api di livello. E se hai trovato di aiuto questo articolo, si prega di contrassegnare accettato. 🙂
    • soluzione creativa hahah 🙂
    • perché abbiamo bisogno di cambiare la sua versione, qualche motivo particolare??
    • io ancora non ho avuto il vero ans per quello che chiedo la stessa domanda come @sameerrana ancora chiedendo perché abbiamo bisogno di cambiare api a livello di versione perché non lavorare di alto livello
  2. 8

    L’ho trovato
    ho avuto lo stesso problema
    vai a values/styles.xml
    cambiare il tema di Base.Tema.AppCompat.Luce.DarkActionBar o qualsiasi cosa si voglia

    Prima :

    <resources>
        <!-- Base application theme. -->
        <style name="AppTheme parent="Theme.AppCompat.Light.DarkActionBar">
            <!-- Customize your theme here. -->
        </style>
    </resources>

    Dopo :

    <resources>
        <!-- Base application theme. -->
        <style name="AppTheme parent="Base.Theme.AppCompat.Light.DarkActionBar">
            <!-- Customize your theme here. -->
        </style>
    </resources>
  3. 2

    Ho fatto un configure build path incluso il andriod 5.1.1 libreria e poi ha fatto un riavvio di eclipse e di questo errore, ma ho risolto

    • Che tipo di configurazione hai fatto a costruire il vostro percorso?
  4. 1

    è solo bisogno di cambiare il AppTheme ad altri temi che modo posso risolvere questo.

  5. 1

    È possibile risolvere questo problema modificando solo il tema di default di app a tema. Devo risolvere tin questo modo solo.

  6. 0

    La soluzione più semplice è cambiare il tema dal menu a discesa della stessa pagina in cui si riceve l’errore, ho.e nella veste grafica e dell’attività dello schermo, in alto c’è un menu a discesa per modificare il tema. Questo ha risolto il problema per me.

  7. 0

    Tenta di ricostruire il progetto ..questo funziona bene per me..
    Nella barra dei menu
    Costruire->Ricostruzione
    O
    aggiungi importazione app.studentlog.R; nel tuo file java.dove studentlog è il nome del progetto.

Lascia un commento