Che cosa <> media?

Ho visto prima in SQL e VB, ora sto reverse engineering di un foglio di calcolo Excel e sono venuto attraverso la seguente formula:

=SE(D23<>0,"Insufficienti",0) 

Sto convertendo al ActionScript:


var result:String = [condition] ? 0 : "Insufficient";

ma io sono sicuro di quello che D23 <> 0 significa, semplicemente “non uguale”?

  • Penso che il <> operatore di disuguaglianza in realtà ha origine dalla lingua BASE.
InformationsquelleAutor mmattax | 2009-02-10

 

6 Replies
  1. 44

    Sì, significa “non uguale”, sia inferiore o superiore.
    e.g

    If x <> y Then

    può essere letto come

    se x è minore di y o x è maggiore di y poi

    Il risultato logico di essere “Se x è nulla tranne uguale a y”

    • bene!! Prima ero confuso con la questione! Sapevo che questo “non equalto” ma chiedevo se c’è qualcos’altro 🙂
  2. 7

    Sì in SQl <> è lo stesso != che non è uguale…..stralci per i valori NULL, naturalmente, in questo caso è necessario utilizzare È NULL o NOT NULL

  3. 6

    Significa non uguale. Lo stesso != si è visto in C stile di lingue, nonché di actionscript.

Lascia un commento