Come filtrare una tabella di Excel in base ai valori di una colonna shard con un’altra tabella?

Per iniziare, non credo VLOOKUP funziona per me, perché ho decine di colonne di ogni tabella.

Diciamo che ho la Tabella 1:

Serial# Value1 Value2 Value3 Value4
1 4 34 65 23
2 123 43 54 46
3 87 98 85 34
4 654 8 645 3

E Tabella 2:

SF
1
3
4

Vorrei un modo per filtrare la Tabella 1 in base ai numeri di serie trovato in SF.

Serial# Value1 Value2 Value3 Value4
1 4 34 65 23
3 87 98 85 34
4 654 8 645 3

Utilizzando un VLOOKUP vorresti dire che devo scrivere una formula, per ogni colonna, voglio riempire. vorrei evitare che.

Grazie

Un po ‘ out of the box, ma un buon ‘ol stile di ricerca di google attraverso questo a me: superuser.com/questions/322455/…. Risolve il problema senza l’utilizzo di VLOOKUP.

InformationsquelleAutor SGHAF | 2014-08-07

One Reply
  1. 9

    In base all’esempio che hai dato non vedo troppe colonne di essere un problema per una formula se stai corrispondenza di tutti i periodici da 1 colonna all’altra.

    Assumendo Table2 in una scheda denominata Tabella2. È possibile utilizzare questa formula alla fine della colonna di Tabella1.

    =SE(ISERROR(VLOOKUP(A1,Tabella2!A:A,1,FALSE)),”FILTRO ME OUT”,”TIENI A ME”)

    Incollare la formula sopra tutta la colonna fino a che l’ultima riga del set di dati.

    Poi filtro sul bordo della colonna in qualsiasi modo si vede in forma, sto assumendo che copre effettivamente il filtraggio sarà eccessivo ma qui è per qualsiasi principianti. Vorrei usare un filtro automatico (Clic in un punto qualsiasi della Tabella1 set di dati, tenere premuto il tasto alt, premere il tasto “DFF” per Excel 2003 e precedenti o Ctrl + Shift + L per le versioni successive di Excel o di passare Dati -> Filtro), selezionare la freccia sul filtro di recente creazione della colonna e filtrare il FILTRO ME OUT” valori.

    InformationsquelleAutor Stan Vest

Lascia un commento