Di Errore di Apache Log – uno sconosciuto filtro non è stato aggiunto: include

Sto diventando più istanze del seguente errore nel mio Mac OS X error_log di Apache:

[Thu Jun 25 17:11:56.789373 2015] [core:error] [pid 277] [client 127.0.0.1:58739] AH00082: an unknown filter was not added: includes

Ho cercato ma non sono stati in grado di individuare quale sia la causa di tutto ciò. C’è un modo per ottenere informazioni più specifiche su ciò che è la causa di questo?

OriginaleL’autore user982124 | 2015-06-25

4 Replies
  1. 7

    Se si dispone di:

    AddOutputFilter INCLUDES .shtml
    

    incluso nella configurazione, in genere quando si hanno mods-enabled/mime.conf, e non hanno attivato il server side include modulo (modules/mod_include.so), quindi qualsiasi query da parte di chiunque di un file con estensione .shtml (se esiste o no, e anche se il Includes opzione non è abilitata) causa il messaggio di errore.

    Se non si utilizza il server side include), è meglio non abilitare il modulo c’è un piccolo rischio potenziale per la sicurezza associati (anche se si sarebbe ancora bisogno di attivare il Includes opzione per essere in effetti). Se si desidera che (innocuo) errore di andare via, si può commentare che AddOutputFilter linea di cui sopra.

    Una cosa da aggiungere è che, almeno per quanto di Apache 2.4.18, questo errore sembra non finire in default del tuo log di errore, anche se si dispone di un separato file di log di errore per il VirtualHost che ha innescato. Poiché avviene per file inesistenti, che lo rende davvero difficile da rintracciare. Ho finito solo una ricerca tutti i miei log per l’indirizzo IP, l’errore non è stato un vero file causando. Si è rivelato alcuni bot era alla ricerca di un .shtml file che non è mai esistito.

    OriginaleL’autore Stephane Chazelas

  2. 2

    In realtà quello che probabilmente è successo è stato:

    1. Hai SetOutputFilter DEFLATE in config
    2. Di NON aver attivato il mod_deflate modulo

    Nel mio caso particolare, ho dovuto semplicemente il commento di questa linea:

    LoadModule deflate_module libexec/apache2/mod_deflate.so
    

    e quindi tutto andava bene.

    Questo probabilmente sarebbe corretto se il messaggio dice “an unknown filtro non è stato aggiunto: sgonfiare” invece di quello in OP.

    OriginaleL’autore lensovet

  3. 0

    Guardando oltre questo thread, sembra che ci sono alcuni modi che possono causare questo errore. Nel mio caso, mod_include non è stato attivato e nel virtual host direttiva che ho avuto:

    Options Includes
    

    Rimozione di tale direttiva o l’attivazione del modulo (a2enmod includere) fisso.

    OriginaleL’autore Rodster001

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *