Git mostra il messaggio di errore “non sembra essere un repository git fatale: L’estremo remoto riattaccato in modo imprevisto”

Ho appena installato GIT nel mio CentOS Linux server e configurato. Quando vado a creare un nuovo repository utilizzando git init funziona bene e dà l’output del comando.
Ma ogni volta che provo a clonare il repository remoto al mio computer la cartella che dà il seguente messaggio:

fatal: '/public_html/repositories/git-test/.git' does not appear to be a git repository
fatal: The remote end hung up unexpectedly

Qualcuno ha incontrato questo problema, quale potrebbe essere il motivo?

  • potete dare il clone di comando che si utilizza per aiutare il debug.
  • Hai detto “locale” – significa che la clonazione in rete? Fa il login sul telecomando ha i privilegi necessari per leggere tutti i file? (E io secondo Nigel richiesta di informazioni.)
  • Questa risposta potrebbe aiutare: stackoverflow.com/a/922566/327862
InformationsquelleAutor user493313 | 2010-11-01

 

One Reply
  1. 11

    Il percorso può essere incompleta. Forse il tuo percorso completo dovrebbe essere qualcosa di più simile a questo: /home/USER/public_html/repositories/git-test.

    • Grazie Kanaka per la risposta, effettivamente iam utilizzando sia mysys GIT e la Tartaruga GIT per questo scopo. Ora ho utilizzato il formato “[email protected]:/public_html/repositories/git-test/”. Poi ho creato il nuovo utente “git” e ha anche aggiunto autorizzato a chiave pubblica per esso nel .ssh file in modo che è possibile accedere in remoto repo. Ora, quando cerco di eseguire per clonare il telecomando repo in locale la cartella mi esce l’errore “”git nessun indirizzo associato col nome”. Penso di essere vicino alla soluzione, ma non so qual è il problema qui.
    • Che potrebbe essere un problema di risoluzione dei nomi. Assicurarsi che qualsiasi cosa si utilizza per myhost.com in realtà si risolve dal computer locale. Inoltre, se continuate ad avere problemi, puoi aggiornare la tua domanda con il comando completo è in esecuzione e l’attuale testo dell’errore. Thx
    • Grazie! Nel mio caso, mi è stato utilizzando un percorso relativo come ../../altri-repo. Utilizza ~/altri-repo invece ha funzionato.

Lascia un commento