Gradle progetto di aggiornamento non riuscito in Android Studio 1.2.1.1

Ho creato il progetto di esempio sulla nuova installazione di Android Studio v 1.2.1.1 e io di fronte a questo messaggio di errore:

Gradle project refresh failed in Android Studio 1.2.1.1 

Vedi immagine qui sotto:

Gradle progetto di aggiornamento non riuscito in Android Studio 1.2.1.1

Così ho cercato di trovare una soluzione su Google e ho controllato

gradle.proprietà file

dove si trova:

dependencies {
        classpath 'com.android.tools.build:gradle:1.2.2'

        //NOTE: Do not place your application dependencies here; they belong
        //in the individual module build.gradle files
    }

Dopo di che ho cercato di aggiornare tutte le librerie SDK tramite SDK manager

E dopo che ho provato a trovare il problema nelle impostazioni (vedi immagine)

Ma tutto senza successo. Perché nella descrizione dell’errore è nulla di non so quale può essere il problema e cosa di riparazione.

Qualche idea per favore?

Molte grazie per qualsiasi aiuto.

Nota:
Compilaton utilizzando Cordova (che utilizza Gradle troppo), senza problemi e senza applicazione viene compilata.

Gradle progetto di aggiornamento non riuscito in Android Studio 1.2.1.1

Davvero nessuno lo sa?
Ho sempre suggerire l’esecuzione di gradlew via riga di comando quando si è in dubbio.

OriginaleL’autore redrom | 2015-06-11

7 risposte

  1. 6

    Per chi è alle prese con questo errore, ecco la mia soluzione:

    Passo 1) fare Clic su “Android Studio” (barra in alto) -> “Preferenze” -> “Costruire, di Esecuzione, di Distribuzione” -> “Strumenti di sviluppo” -> “Gradle”

    E selezionare “Uso locale gradle di distribuzione” e trovare il percorso per il file Gradle
    (es. /Applicazioni/Android Studio.app/Contents/gradle/gradle-2.8)

    Passo 2) fare Clic su “File” (barra in alto) -> “Struttura di Progetto” -> Selezionare “app” nella sezione “Moduli”.
    Quindi, assicurarsi di aver impostato il Compilatore Versione dell’SDK e Costruire Strumenti Versione

    Passo 3) Aprire il progetto -> Apri “.gradle” file ” e poi rimuovere le seguenti righe:

    android {
        compileSdkVersion XX
        buildToolsVersion 'XX.X.X'
    }

    Punto 4) fare Clic su “Sync Progetto con Gradle File” pulsante.

    Le istruzioni complete qui
    Gradle progetto di aggiornamento non riuscito in Android Studio 1.2.1.1

    Grazie per questa soluzione.

    OriginaleL’autore pmaroco

  2. 1

    Ho provato più soluzioni per questo.
    Infine, in seguito ha lavorato per me.

    1. Chiudere Android Studio
    2. Eliminare (o meglio spostarli da qualche parte per avere un backup) .gradle dal seguente percorso :

    Android Studio > File(barra dei Menu) > Impostazioni > Costruire, l’Esecuzione, la Distribuzione > Strumenti > Gradle > (Nel riquadro a destra) Servizio Percorso di Directory: “Alcuni percorsi” \ .gradle

    Andare a “Qualche” Percorso ed Eliminare o prendere il backup .gradle cartella .

    1. Avviare Android Studio e/ricostruzione di aggiornamento. Questo crea l’ .gradle cartella

    Grazie 🙂

    OriginaleL’autore Harshil

  3. 1

    Questo potrebbe essere troppo tardi per rispondere. Ma questo potrebbe aiutare qualcuno.

    Nel mio caso non c’era problema di JDK percorso.

    Ho appena impostare la corretta JDK percorso per Android Studio 2.1

    OriginaleL’autore pgp

  4. 0

    Set chmod 775 .gradle dir nella home directory aiutato a me ha risolto.

    Fare questo è corretto se si pensa di risolvere il proprio problema.

    OriginaleL’autore redrom

  5. 0

    File -> Invalidare la Cache /Restart -> Invalidare e Riavvio ha funzionato per me.

    OriginaleL’autore Manikandan K

  6. 0
    buildscript {
        repositories {
            mavenCentral()
        }
        dependencies
        {
            classpath 'com.android.tools.build:gradle:2.3.0'
        }
    }
    allprojects 
    {
        repositories 
        {
            mavenCentral()
        }
    }

    OriginaleL’autore Syed Danish Haider

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *