Il compositore non riconosce PHP 7

Ho creato un travis profilo per testare il mio progetto da PHP 5.6 PHP 7.

Ricevo il seguente messaggio di errore quando il compositore di esecuzione:

Your requirements could not be resolved to an installable set of packages.
  Problem 1
    - This package requires php ~5.4 but your PHP version (7.0.1-dev) does not satisfy that requirement.

il comando che io sono in esecuzione è:

composer update -n

con travis set di ambiente PHP 5.6 io non incorrere in questo problema

Si può fornire la richiesta di blocco del vostro compositore.json?

OriginaleL’autore azngunit81 | 2015-12-08

4 Replies
  1. 5

    Un pacchetto che si utilizza, o il vostro proprio software di per sé, richiede esplicitamente un PHP 5.x versione (~5.4), con x almeno 4 o superiore (cioè dovrebbe eseguire con PHP 5.5, 5.6, o anche 5.10 se esiste).

    Questo pacchetto non consente PHP 7. Ecco perché non si può eseguire composer update con successo.

    aveva un blocco php nel "php": "~5.4",. tks

    OriginaleL’autore Sven

  2. 16

    Se la piattaforma requisito è nella root del vostro pacchetto, si può risolvere modificando composer.json come tale

    {
        "require": {
            "php": "~5.4 | ^7.0"
        } 
    }

    Si potrebbe anche cercare di ignorare i requisiti della piattaforma, ma dipende se si vuole realmente vedere che succede:

    $ composer install --ignore-platform-reqs

    Per riferimento, vedere https://getcomposer.org/doc/03-cli.md#install.

    Non mi piace usare l’opzione –ignore-piattaforma-reqs come sto usando travis fare prove continue.
    Come circa la regolazione della piattaforma requisiti come suggerito, @azngunit81?

    OriginaleL’autore localheinz

  3. 4

    controllare il compositore.file json,
    eliminare questo codice:

     "config": {
        "bin-dir": "bin",
        "platform": {
            "php": "5.x.1"  //Or change 5.x.1 to your php version
        }
    },
    Risolto il mio problema. Sono stato in esecuzione PHP7, ma continuava a dire che ero su 5.5.9. E questo è il motivo. Grazie!

    OriginaleL’autore baoniu

  4. 0

    cambiare php predefinito V

    sudo update-alternatives --config php

    OriginaleL’autore D.Y.F

Lascia un commento