L’installazione di specifici laravel 5 versione con il compositore crea-progetto

Oggi provo a installare specifici laravel versione con composer create-project laravel/laravel=5.1.8 your-project-name --prefer-dist, perché alcuni dei plugin di problemi con la versione 5.1.9 e sopra.

Tuttavia, l’installazione fallisce e si dice Could not find package laravel/laravel with version 5.1.8. Come posso installarlo con il compositore?

OriginaleL’autore user1995781 | 2015-08-17

3 Replies
  1. 7

    si può fare:

    composer create-project laravel/laravel myproject --prefer-dist v5.1.8

    Per vedere le versioni disponibili, si può visitare il suo packagist pagina (in basso a destra):

    https://packagist.org/packages/laravel/framework

    AGGIORNAMENTO:

    Non c’è in realtà un tag per la v5.1.8 per il pacchetto di laravel/laravel,
    Il problema è il quadro(core) di laravel..

    Cosa si può fare per risolverlo è quello di modificare il compositore.json:

    "require": {
            "php": ">=5.5.9",
            "laravel/framework": "5.1.8"
        },

    E fare composer update "laravel/framework"

    Il metodo solo creare una cartella denominata v5.1.8, ma ancora installare l’ultima versione, non la versione 5.1.8
    Ho aggiornato la mia risposta. Tuttavia, è giusto che il compositore non è in grado di trovare il pacchetto 5.1.8.. Se guardiamo i tag su Laravel git hub repo, l’ultima tag è stato solo fino a 5.1.4, forse è questo il motivo non è in grado di trovare? perché se si tenta di modificare il 5.1.8 a 5.1.4, è in grado di installare..
    Grazie mille per il vostro aggiornati risposta. È un modo per farlo con il compositore crea-progetto?
    Non c’è modo. Come il compositore crea-progetto installa l’effettivo laravel applicazione e non sono il core.. vedrete che se si esegue il compositore crea-progetto laravel/laravel –preferisce-dist, ha un compositore.file json e richiede “laravel/framework” (che è il core).. È necessario aggiornare manualmente se si desidera una versione specifica del core. Basta assicurarsi che se si installa un laravel 5~ applicazione, la sua “laravel/quadro” dipendenza dovrebbe essere intorno la versione 5~ pure per evitare problemi di compatibilità..

    OriginaleL’autore Darryldecode

  2. 7

    Una risposta semplice che posso pensare è

    composer create-project laravel/laravel <app name> "5.1.*"

    Sostituire solo < nome dell’app > con il nome dell’applicazione e potrete installare laravel del 5.1 distribuzione.

    Ma questo non è possibile installare una specifica laravel 5 versione , installa l’ultima versione di 5.1.
    Basta specificare l’esatta versione di laravel si desidera installare e installare la versione richiesta, se esiste.

    OriginaleL’autore Farveaz

  3. 1

    Utilizzare il seguente comando:

    composer create-project laravel/laravel my_project 5.1.8

    È inoltre possibile specificare una versione e, per esempio 5.1 e le sue patch, in questo modo (consigliato):

    composer create-project laravel/laravel my_project 5.1.*
    Provato con il tuo metodo ma non funziona e mostra il messaggio di errore stesso.
    Che tipo di errore hai trovato ?
    non trovare il pacchetto laravel/laravel con la versione 5.1.8. Si può provare a eseguire il comando, verrà visualizzato l’errore.
    Provate questo “compositore creare-progetto laravel/laravel=5.1.8 il-progetto-nome-preferiscono-dist”
    Stai dicendo a me di provare il metodo che ho provato come scritto nella domanda?

    OriginaleL’autore ifma

Lascia un commento