non è possibile importare com.google.android.mappe.MapView

Purtroppo dopo una lunga giornata, la ricerca non ho trovato nulla di utile per me.

Il mio Problema è che non posso usare “estendere MapActivity” o meglio importare la biblioteca.
Ho provato ad usare “Google API” invece di “API di Android” come consigliato in qualche altro thread, ma il problema è che non ho le “API di Google” nel mio SDK Manager per il download o scegliere.

Il mio Android SDK Manager
Così, ho nel mio “Android SDK Manager” solo Android Api da “Android 1.5 API (3)” per “Android 4.0.3 API (15)” e non “API di Google”.

Ecco un esempio in cui le “API di Google” è disponibile all’interno del “Android 4.0.3 API (15)” Installare le Api di Google…

C’è qualche possibilità di scaricare o importare le “API di Google” in un modo diverso o sto facendo qualcosa di sbagliato?

Andare alle proprietà del progetto e quindi sul separatore di Android scegliere API di Google per la piattaforma corrente. Spero che questo ti aiuta

InformationsquelleAutor Yves | 2012-03-30

3 Replies
  1. 12

    Ho avuto lo stesso problema con una soluzione diversa, ho

    1. diritto cliccato sul mio progetto nel Pacchetto Exploere e selezionate “Build Path->Configure Build Path”
    2. Selezionato “Java Build Path” e “Librerie” scheda
    3. Selezionate “Add External Jar”
    4. Navigato il mio sdk/add-ons/addon-google_apis_google_inc_-/libs
    5. Selezionato “maps.jar”

    Mi è stato poi in grado di importare com.google.mappe.*

    InformationsquelleAutor user330844

  2. 3

    Si potrebbe aggiungere “Android” tag alla tua domanda per ottenere una migliore assistenza.

    “Api di Google” devono essere indicati all’interno di ‘un po’ di le API di Android come un subcatory su Android SDK Manager. Ho appena controllato il mio SDK manager e Api di Google può essere selezionato e installato all’interno di Android 1.6 e 2.1 4.0

    Spero che questo aiuta, se non ri-scaricare e ri-installare l’Android SDK manager?
    non è possibile importare com.google.android.mappe.MapView

    Mi dispiace solo notato la tua domanda di aggiornamento, Google non sembra aggiornato e re-release ci Api per ogni versione di Android, i due progetti sono separati, quindi non ci sono grosse lacune tra le versioni posso solo trovare 1.6, 2.1 e 4.0 su di me.
    Grazie per la veloce risposta. Finalmente ho trovato una soluzione e risolto con l’aggiornamento di eclipse, come consigliato in stackoverflow.com/questions/7892220/…

    InformationsquelleAutor Martin Sykes

  3. 0

    Provare ad aggiungere il seguente costruire.gradle file:

    dependencies {
        compile 'com.google.maps.android:android-maps-utils:0.3+'
    }

    InformationsquelleAutor ARPITA BALI

Lascia un commento