Ottenere incompatibile versione debugger errore in eclipse PHP

Ottenere incompatibile versione debugger
Il debugger remoto versione potrebbe non corrispondere il previsto protocollo versione
(2006040705). Mostra di errore pop-up dopo ogni po ‘ di tempo

Sto usando

Eclipse per gli Sviluppatori PHP

Versione: Helios Service Release 1
Build id: 20100917-0705

InformationsquelleAutor Vicky | 2010-12-29

 

4 Replies
  1. 16

    Sembra essere un bug in Eclipse PDT e secondo questo rapporto:
    Bug 271071 – “Incompatibile versione debugger” quando non si esegue il debug, il bug sembra risolvere, quando si chiude TUTTI i progetti dell’area di lavoro e quindi riaprire a seconda di quale avete bisogno.

    Personalmente ho risolto cambiando le porte di debug in “Preferenze -> PHP -> Debug -> Installato Debugger”, con questi valori:

    Zend Debugger (30000)

    XDebug (19000)

    Che Funziona per me, forse devi provare con un altro porte.

    Riguarda

    • Buona idea! Che errore è fastidioso e non ero sicuro di cosa esattamente era da (io non uso PHP debugger, non ho mai pensato cercando di connettersi) — scoperto che stava cercando di Zend Debugger sulla porta 10000 che è il mio tunnel SSH per Webmin sul mio server, in modo che, ovviamente, non la corretta versione del protocollo lol
  2. 7

    Ho avuto lo stesso problema e la causa è legata alla rete bittorrent /utorrent barra degli strumenti del browser.
    È necessario rimuovere la barra degli strumenti e riavviare il browser per risolvere il problema.

  3. 0

    semplicemente di chiudere tutte le applicazioni in esecuzione e codici e riavviare nuovamente l’applicazione. Funziona bene.

Lascia un commento