Plug-in com.android.ide.eclipse.adt è stato in grado per classe di carico android

Io sono nuovo di android sviluppo
Il mio eclipse funzionava correttamente. Ma ora quando avvio un nuovo progetto dà un errore
Problema durante l’apertura della procedura guidata
Selezionato guidata non può essere aperto

Il messaggio di errore Dettagliato è

The selected wizard could not be started.
Plug-in com.android.ide.eclipse.adt was unable to load class com.android.ide.eclipse.adt.internal.wizards.newproject.NewProjectWizard.
An error occurred while automatically activating bundle com.android.ide.eclipse.adt (239).

Non riesco a correre esistente progetto Android anche.Ma posso iniziare un nuovo progetto java ed eseguire.
Perché questo sta accadendo

InformationsquelleAutor Johnykutty | 2012-04-14



19 Replies
  1. 14

    Se non hai aggiunto ADT quindi eseguire i passaggi Seguenti.

    Aiuto -> Aggiungi Nuovo Software -> Aggiungi.

    In Name opzione scrivere ADT

    E se avete installato ADT nel tuo Computer, quindi aggiungere il suo percorso in Location come

    jar:file:/D:/ADT-16.0.1.zip!/

    E ADT verrà installato.

    E se c’è un problema, provare a rimuovere l’adt e installare di nuovo.

    1) remove the ADT repo (Window->Preferences->Install/Updates->Available Software Sites)
    2) add Indigo repo ("http://download.eclipse.org/releases/indigo")
    3) run updates
    4) add ADT repo again and install
  2. 8

    Per me,quello che sembrava un lavoro è stato:

    1.Riavviare l’applicazione
    2.(O) il Riavvio del computer

    Ho ancora avuto alcuni problemi.Alcuni progetti, in forza di carico.Io non sono sicuro di quale sia il problema o è stato.Penso che la reinstallazione di ADT dovrebbe fare il trucco.

  3. 1

    Ho avuto un problema simile, e sembra essere l’org.eclipse.objectteams plugin causando problemi per me. Quello che dovevo fare era togliere il plugin dal mio plugin di Eclipse directory come segue:

    mv ~/.eclipse/*/plugins/org.eclipse.objectteams* ~/someDIR

    Sembra che ci sia problemi di dipendenza con le più recenti versioni di Eclipse. Scusate se mi puoi fornire ulteriori informazioni.

    Magari vedere https://bugs.eclipse.org/bugs/show_bug.cgi?id=350133.

  4. 1

    Sto postando questa risposta per le persone che si riferisce a questo post in futuro.

    I metodi menzionati richiederà più tempo. Ho capito il problema aggiornando il plugin.
    Ma non è che il modo come vic12 è menzionato. Io ho fatto nel seguente modo

    Aiutare a > Installa un nuovo software > fare clic sul link Quello che è già installato si può vedere un elenco dei software installati. È possibile scegliere e aggiornare una qualsiasi come si desidera. Se si fa clic su check for update per l’aggiornamento di tutti i software che abbiamo installato, ci vorrà un sacco di tempo. In questo modo è possibile aggiornare quello che si desidera. Questo può essere fatto in un minuto. esso consente di risparmiare tempo.

  5. 1

    Nel mio caso il riavvio del computer risolto tutti i problemi senza dover installare plugin ADT.
    BTW, io sto usando il MAC + ADT_v22

  6. 1

    Vai alla Guida – eclipse di mercato – ricerca per adt. Quindi aggiornare o installare. Questo ha funzionato per me.

  7. 0

    Ho avuto lo stesso problema e ho iniziato a leggere le risposte di cui sopra. poi ho smesso di leggere e appena riavvio di eclipse e si è lavorato per me! (questa è la mia prima soluzione per tutti i dispositivi elettronici e generalmente funziona 🙂

  8. 0

    Questo può verificarsi se si rimuove Android dal tuo costruire il percorso. Basta provare a ricollegare JRE6 o 7 e riavviare il programma. Eclipse in grado di gestire per voi.

    • Si prega di estendere la tua risposta e aggiungere le istruzioni su come ricollegare JRE6 O 7 se è possibile.
  9. 0

    Se siete su un Mac e utente Eclipse ADT, andare a ADT -> Impostazioni -> Android. Ci si dovrebbe trovare un’opzione per l’impostazione di Android SDK posizione. Basta sfogliare l’ADT, e selezionare la cartella SDK.

    Questo, naturalmente, può essere fatto solo dopo l’SDK è stato installato.

    Plug-in com.android.ide.eclipse.adt è stato in grado per classe di carico android

  10. 0

    Basta riavviare eclipse. Sembra eclipse sta avendo alcuni bug di cui è leader di altri componenti in modo corretto caricamento. O prima di iniziare sdk manager da sfondo e poi eclipse.

  11. 0

    Spero che sarebbe di aiuto a qualcuno:
    Ho avuto lo stesso problema e ironia della sorte il problema era in un semplice codice di errore. Per qualche motivo questo errore causato Eclipse per reagire con linee rosse in tutto il codice e il salvataggio di errori così come il messaggio di errore citato in questo post.

    Ho risolto il problema (eliminazione di un extra }) e tutti i problemi sono scomparsi.

    Non so perché Eclipse reazione esagerata questa volta, ma è un’altra opzione per il check prima di installare, disinstallare o aggiornare nulla.

    Buona fortuna.

  12. 0

    Voglio solo aggiungere questo qui, in quanto il problema si è verificato solo con me. Cosa che ho fatto è stato close eclipse, riaprirlo e poi ha iniziato a lavorare. Se questo non risolve il problema, allora vi consiglio di andare con @Bhavin risposta.

  13. 0

    Si potrebbe avere memorizzato due ADT plugin uno con e l’altro con il file zip devi eliminare uno di loro
    Aiuto -> Installa un nuovo software -> software Disponibili per i siti -> e la rimozione di uno di adt plugin.

Lascia un commento