Scelto jQuery plugin non funziona.

Utilizzando Scelto la versione 1.0.0
Ho incluso i seguenti file

link(href='css/chosen.css', rel="stylesheet", type="text/css");
script(src='js/chosen.jquery.min.js')
script.
    $(".chosen-select").chosen()

body
  select(data-placeholder="Choose a country...", multiple style="width:350px;" ).chosen-select
            <option value=""></option>
            <option value="United States">United States</option>
            <option value="United Kingdom">United Kingdom</option>
            <option value="Afghanistan">Afghanistan</option>
            <option value="Aland Islands">Aland Islands</option>
            <option value="Albania">Albania</option>
            <option value="Algeria">Algeria</option>
            <option value="American Samoa">American Samoa</option>

Il codice di cui sopra dà un disfunzionali select box sopra Il display è lo stesso

select(multiple, style="width:350px;")
            <option value=""></option>
            <option value="United States">United States</option>

All’analisi vedo, che sia chosen.css e chosen.jquery.min.js non hanno classe chosen-select sto usando la versione jQuery v1.10.2 Anche io sono di caricamento jQuery come il primo file della pagina per evitare il conflitto.

Grazie per l’aiuto.

 

3 Replies
  1. 5

    Aggiunta di

    script.
            $(document).ready(function(){
                $(".chosen-select").chosen()
            });

    Invece di $(".chosen-select").chosen() rende il lavoro!

  2. 0

    Il mio non ha funzionato, invece, ha funzionato da

    <script type="text/javascript" src="js/chosen.jquery.js" >
    </script>   
    <script>
        `Enter only enter chosen related code here`
    </script>

Lascia un commento