SWFUpload su HTTPS e non di lavoro

Ho problemi con il caricamento di file con SWFUpload se il target servlet è in ascolto su HTTPS.
HTTP funziona benissimo.

Il problema è solo quando si utilizza FireFox o Opera. Su IE funziona benissimo – non provato altri browser.

EDIT:
Messaggio di errore, come previsto dal SWFUpload quando in modalità di debug:

SWF DEBUG: Evento: uploadProgress (APERTO): ID File: SWFUpload_0_0 SWF DEBUG: Evento: uploadError : IO di Errore : File ID: SWFUpload_0_0. IO di Errore: Errore #2038
SWF DEBUG: Evento: uploadComplete : ciclo di Carica completo.

Eventuali messaggi di errore o giù di lì?
Messaggio di errore, come previsto dal SWF nella sezione di MODIFICA del messaggio.
do u hanno un url che ho potuto colpire per verificare il certificato? u aggiunto in una risposta che il certificato problema sembra essere con l’autorità di certificazione, ha u già confermato?
Mi dispiace ma non posso darti l’URL. Attualmente stiamo allestendo il nostro server per l’autorità di certificazione in modo che possiamo provare Se è davvero il problema.

OriginaleL’autore Drejc | 2009-11-24

5 Replies
  1. 6

    Possibilmente un certificato problema.

    Controllare se ci sono eventuali certificati relativi avvisi quando si apre il sito di destinazione in quei browser.

    Aprire il certificato e controllare gli avvisi in là pure.

    OriginaleL’autore eglasius

  2. 3

    Si tratta certamente di un problema certificato – funziona con HTTPS, Firefox e un ufficiale certificato.

    Io uso SWFUpload in combinazione con HTTPS sul sito invoiceplatform.com e funziona con IE, Safari, Firefox e Chrome (non si prova con altri browser). Sul test server Firefox non funziona con HTTPS perché non c’è nessun certificato ufficiale configurato.

    OriginaleL’autore penguintux

  3. 2

    2038 È un Flash IO di Errore:

    “Flash IO Errori non sono molto utili. Lo stesso paio di numeri di errore viene restituito per appena circa tutto.

    Qui ci sono alcuni problemi comuni che causano questi codici di errore:

    • URL non valido
    • Server max post dimensione o dimensione max upload superato
    • Server in modo imprevisto interrompe la connessione
    • File di Zero byte caricati
    • L’Autenticazione di base non è riuscito

    Per eseguire il debug di questi problemi che avevo prima verificare che il mio upload usando HTML standard caricare il modulo indicando il mio upload.php”

    Se fosse http suggerirei di fiddler o wireshark, ma non credo che sarà di aiuto per https.

    Funziona perfettamente su HTTP e servlet funziona anche. Il problema si verifica solo su HTTPS e FF / Opera. Presumo che ci sia qualche problema certificato come Freddy citati, ma la cosa difficile è capire perché.

    OriginaleL’autore Mike Blandford

  4. 0

    Ultima volta che ho avuto qualche problema enorme sul sito con la protezione ssl e SWFUpload e altri flash uploaders. C’era sempre errore #2038. Inoltre c’era un problema con la condivisione di contenuti dal sito https su Facebook. Ho speso un sacco di ore per trovare la soluzione e l’ho trovato! Non c’era problema con i certificati ssl.

    Prima di tutto originali e non auto certificati generati se si hanno lo stesso problema perchè il Flash ha problemi con la seconda. Il server del sito è di Nginx così potrai installare i certificati correttamente qui è l’istruzione. E il punto principale è Concatenare il certificato principale e certificato intermedio. Se non lo farà la vostra pagina sarà funziona correttamente ma non il flash uploader e anche quando si tenta di

    curl https://your-site.com

    si potrebbe vedere di errore che spiega che c’è un problema con il certificato.

    Ciò che è interessante è che su Windows e Mac Os macchine per il flash funziona correttamente anche senza la concatenazione di certificati e non c’è problema su Ubuntu. Ma su ogni sistema è un problema con la condivisione su Facebook in quanto dipende da FB la configurazione del server.

    Qual è il problema di ubuntu? Attualmente sto vivendo ‘un po’ di utenti con firefox avere problemi, ho una vera SSL e non ho probs con il mio firefox, alcune persone tuttavia.
    Stesso problema qui ChrisAdmin. Hai trovato una soluzione?

    OriginaleL’autore snikolau

Lascia un commento